Cloud Device unavailability
Incident Report for Genymotion
Resolved
A network issue was causing some of our servers to be unreachable. The issue is now resolved.
Posted Sep 27, 2021 - 07:58 UTC
Investigating
An internal service error is currently preventing some users to start virtual devices in the "North America" zone. We are working on resolving the issue.
Posted Sep 27, 2021 - 07:53 UTC
This incident affected: Cloud Devices (North America).