Latency
Incident Report for Genymotion
Resolved
Thanks to our new clients, we have managed to identify many instabilities in our product, and will work even harder to make it more robust.
We tweaked and fixed as many thing as we could for now, and most API are back to their normal state

We apologize for the inconvenience, and thank you for you trust in.

If you still encounter issue, or have any question related to the incident, please feel free to contact our support via the in-app form.
Posted Jan 28, 2022 - 07:43 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 26, 2022 - 15:39 UTC
Monitoring
We have implemented a solution and are monitoring the situation.
Latency is still higher than usual, but all API calls should now respond properly.
Posted Jan 25, 2022 - 16:11 UTC
Identified
We have identified the reason of the observed latency and are working on fixing it.
Posted Jan 25, 2022 - 15:58 UTC
Investigating
We are experiencing higher than average latency on our APIs.
We are currently investigating the situation.
Posted Jan 25, 2022 - 15:06 UTC
This incident affected: Cloud API.