Latency issues

Incident Report for Genymotion

Resolved

This incident has been resolved.
Posted Dec 13, 2024 - 09:33 UTC

Investigating

We are currently investigating this issue.
Posted Dec 13, 2024 - 08:41 UTC
This incident affected: Genymotion SaaS - Web application and Genymotion SaaS - Automation APIs.