Cloud Device unavailability
Incident Report for Genymotion
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 14:48 UTC
Investigating
An internal service error is currently preventing some users to start virtual devices. We are working on resolving the issue.
Posted Nov 15, 2022 - 14:30 UTC
This incident affected: Cloud Devices (Western Europe, North America).