Network latency
Incident Report for Genymotion
Resolved
This incident has been resolved.
Posted Feb 23, 2022 - 21:39 UTC
Identified
We encounter some network latency impacting some of our services.
We are working on mitigating this issue.
Posted Feb 23, 2022 - 15:28 UTC
This incident affected: Cloud Portal, Cloud API, Desktop API, STUN (Session Traversal Utilities for NAT), and Website.